summaryrefslogtreecommitdiff
path: root/openfortivpn/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'openfortivpn/PKGBUILD')
-rw-r--r--openfortivpn/PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/openfortivpn/PKGBUILD b/openfortivpn/PKGBUILD
new file mode 100644
index 0000000..177522f
--- /dev/null
+++ b/openfortivpn/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: asamk
+# Contributor: envolution
+# Contributor: Olliver Schinagl <oliver@schinagl.nl>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+pkgname=openfortivpn-git
+_pkgname=openfortivpn
+pkgver=1.23.1+r0+ga011b5c
+pkgrel=1
+pkgdesc="An open implementation of Fortinet's proprietary PPP+SSL VPN solution"
+arch=(x86_64)
+url=https://github.com/adrienverge/openfortivpn
+license=(GPL-3.0-only)
+depends=(
+ glibc
+ openssl
+ ppp
+)
+makedepends=(
+ git
+)
+provides=('openfortivpn')
+conflicts=('openfortivpn')
+backup=(etc/openfortivpn/config)
+# https://github.com/adrienverge/openfortivpn.git
+source=(openfortivpn.tar.gz)
+sha256sums=('387ad30d19eee76f1e363e3e74a75817e1eed681446a84e0216cbe6f78686c13')
+
+prepare() {
+ cd openfortivpn
+ autoreconf -fiv
+}
+
+pkgver(){
+ cd "${srcdir}/openfortivpn"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/+/g;s/v//' ||
+ printf "r%s+%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd openfortivpn
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-ppp \
+ --with-systemdsystemunitdir=no
+ make
+}
+
+package() {
+ make DESTDIR="${pkgdir}" -C openfortivpn install
+}
+
+# vim: ts=2 sw=2 et: