summaryrefslogtreecommitdiff
path: root/hwdata/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'hwdata/PKGBUILD')
-rw-r--r--hwdata/PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/hwdata/PKGBUILD b/hwdata/PKGBUILD
index 386e219..f2b0da9 100644
--- a/hwdata/PKGBUILD
+++ b/hwdata/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=hwdata
-pkgver=0.393
-pkgrel=1
+pkgver=0.395
+pkgrel=2
pkgdesc="hardware identification databases"
-makedepends=('git')
replaces=('hwids')
-url=https://github.com/vcrhonek/hwdata
+url=https://github.com/vcrhonek/$pkgname
license=('GPL-2.0-or-later')
arch=('any')
-source=("git+https://github.com/vcrhonek/hwdata.git#tag=v${pkgver}")
+source=("https://github.com/vcrhonek/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('3ad259200a6ecad3f9e2e05a59216494b56880f78b7749026a41f099a02a942917c11532540fcd5b7c74fe94d95f1665e3933ef580e048ccc87cafb646d2dd7a')
validpgpkeys=('3C40194FB79138CE0F78FD4919C2F062574F5403') # Vitezslav Crhonek
-b2sums=('c7ebe6f96283123816adfa4d40a416b125f5f782646683575182de077523abe4c4505d10df3f5cf3e484675ceb05b78a6e0b58b8e40b5803129ea8d9721092e5')
build() {
- cd ${pkgname}
+ cd ${pkgname}-${pkgver}
./configure --prefix=/usr --disable-blacklist
}
package() {
- cd ${pkgname}
- [ -f /usr/share/hwdata/iab.txt ] && rm /usr/share/hwdata/iab.txt
- [ -f /usr/share/hwdata/oui.txt ] && rm /usr/share/hwdata/oui.txt
- [ -f /usr/share/hwdata/pci.ids ] && rm /usr/share/hwdata/pci.ids
- [ -f /usr/share/hwdata/usb.ids ] && rm /usr/share/hwdata/usb.ids
+ cd ${pkgname}-${pkgver}
+ [ -f /usr/share/$pkgname/iab.txt ] && rm /usr/share/$pkgname/iab.txt
+ [ -f /usr/share/$pkgname/oui.txt ] && rm /usr/share/$pkgname/oui.txt
+ [ -f /usr/share/$pkgname/pci.ids ] && rm /usr/share/$pkgname/pci.ids
+ [ -f /usr/share/$pkgname/usb.ids ] && rm /usr/share/$pkgname/usb.ids
make DESTDIR="${pkgdir}" install
}
-sha512sums=('SKIP')