summaryrefslogtreecommitdiff
path: root/xorg-input-libinput/PKGBUILD
diff options
context:
space:
mode:
authorsrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-05 15:29:27 -0500
committersrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-05 15:29:27 -0500
commit81555e3bd23c74ce915d246ca51fa65d84c22ae7 (patch)
tree1ba136af6b87426d37d010866b5cdac110eaeaa8 /xorg-input-libinput/PKGBUILD
First commitdevelop
Diffstat (limited to 'xorg-input-libinput/PKGBUILD')
-rw-r--r--xorg-input-libinput/PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/xorg-input-libinput/PKGBUILD b/xorg-input-libinput/PKGBUILD
new file mode 100644
index 0000000..b542434
--- /dev/null
+++ b/xorg-input-libinput/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: André Silva <emulatorman@hyperbola.info>
+# Contributor: Márcio Silva <coadde@hyperbola.info>
+
+# Based on xf86-input-libinput package
+
+pkgname=xorg-input-libinput
+pkgver=0.25.1
+pkgrel=2
+pkgdesc="Generic input driver for the X.Org server based on libinput"
+arch=('i686' 'x86_64')
+license=('Expat')
+url="https://xorg.freedesktop.org/"
+depends=('libinput>=1.2.0')
+makedepends=('xenocara-server-devel' 'X-ABI-XINPUT_VERSION=24.1' 'libxi' 'libx11' 'xenocara-proto')
+provides=('xf86-input-libinput')
+conflicts=('xf86-input-libinput' 'xenocara-server<1.19' 'X-ABI-XINPUT_VERSION<24' 'X-ABI-XINPUT_VERSION>=25')
+replaces=('xf86-input-libinput')
+groups=('xenocara-drivers' 'xorg-drivers')
+source=(https://xorg.freedesktop.org/releases/individual/driver/xf86-input-libinput-$pkgver.tar.bz2{,.sig})
+sha512sums=('9a8d16bdffb73a5318d22e352826c410ccb6f8c7ade31c23823bd6c17202bb67e917dfe8d4cab6e54fdf15f201d14d80b6306cedc5f93f66989edfcab5082ece'
+ 'SKIP')
+validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
+
+prepare() {
+ cd "xf86-input-libinput-$pkgver"
+ autoreconf -vfi
+}
+
+build() {
+ cd "xf86-input-libinput-$pkgver"
+ ./configure --prefix=/usr \
+ --disable-static
+ make
+}
+
+package() {
+ cd "xf86-input-libinput-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}