summaryrefslogtreecommitdiff
path: root/python-zipp/PKGBUILD
diff options
context:
space:
mode:
authorsrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-05 15:29:27 -0500
committersrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-05 15:29:27 -0500
commit81555e3bd23c74ce915d246ca51fa65d84c22ae7 (patch)
tree1ba136af6b87426d37d010866b5cdac110eaeaa8 /python-zipp/PKGBUILD
First commitdevelop
Diffstat (limited to 'python-zipp/PKGBUILD')
-rw-r--r--python-zipp/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/python-zipp/PKGBUILD b/python-zipp/PKGBUILD
new file mode 100644
index 0000000..9997d51
--- /dev/null
+++ b/python-zipp/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer (Arch): Felix Yan <felixonmars@archlinux.org>
+# Maintainer: Tobias Dausend <throgh@hyperbola.info>
+# Contributor: rachad
+
+pkgname=python-zipp
+pkgver=2.2.0
+pkgrel=2
+pkgdesc="Pathlib-compatible object wrapper for zip files"
+url='https://github.com/jaraco/zipp'
+license=('Expat')
+arch=('any')
+depends=('python')
+makedepends=('python-setuptools-scm' 'python-toml')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jaraco/zipp/archive/v$pkgver.tar.gz")
+sha512sums=('bd65e0adaf27d540dba8b7ef8f98f0955d817eb3c6d2275083c4ac80edf5afc504be8e8a232874cf861386ae351b66d06fcfc68eacadae7ad7177df5cbfa5b76')
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+
+build() {
+ cd zipp-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd zipp-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+}