summaryrefslogtreecommitdiff
path: root/hwdata/PKGBUILD
diff options
context:
space:
mode:
authorsrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-05 15:29:27 -0500
committersrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-05 15:29:27 -0500
commit81555e3bd23c74ce915d246ca51fa65d84c22ae7 (patch)
tree1ba136af6b87426d37d010866b5cdac110eaeaa8 /hwdata/PKGBUILD
First commitdevelop
Diffstat (limited to 'hwdata/PKGBUILD')
-rw-r--r--hwdata/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/hwdata/PKGBUILD b/hwdata/PKGBUILD
new file mode 100644
index 0000000..386e219
--- /dev/null
+++ b/hwdata/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+pkgname=hwdata
+pkgver=0.393
+pkgrel=1
+pkgdesc="hardware identification databases"
+makedepends=('git')
+replaces=('hwids')
+url=https://github.com/vcrhonek/hwdata
+license=('GPL-2.0-or-later')
+arch=('any')
+source=("git+https://github.com/vcrhonek/hwdata.git#tag=v${pkgver}")
+validpgpkeys=('3C40194FB79138CE0F78FD4919C2F062574F5403') # Vitezslav Crhonek
+b2sums=('c7ebe6f96283123816adfa4d40a416b125f5f782646683575182de077523abe4c4505d10df3f5cf3e484675ceb05b78a6e0b58b8e40b5803129ea8d9721092e5')
+build() {
+ cd ${pkgname}
+ ./configure --prefix=/usr --disable-blacklist
+}
+package() {
+ cd ${pkgname}
+ [ -f /usr/share/hwdata/iab.txt ] && rm /usr/share/hwdata/iab.txt
+ [ -f /usr/share/hwdata/oui.txt ] && rm /usr/share/hwdata/oui.txt
+ [ -f /usr/share/hwdata/pci.ids ] && rm /usr/share/hwdata/pci.ids
+ [ -f /usr/share/hwdata/usb.ids ] && rm /usr/share/hwdata/usb.ids
+ make DESTDIR="${pkgdir}" install
+}
+sha512sums=('SKIP')