summaryrefslogtreecommitdiff
path: root/emacs/PKGBUILD
diff options
context:
space:
mode:
authorsrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-08 16:11:09 -0500
committersrv <enmanuel.saravia.externo@pandero.com.pe>2025-05-08 16:11:09 -0500
commit342ac6fb859381069c7bad8c9bc4a0dfa3a40d6f (patch)
treeaefd83f1665ff62b38aeed32d4c74b60ec9e5afb /emacs/PKGBUILD
parentb7302c99914f165776b48f25b7ed12d630b910a4 (diff)
add emacs 30 and linux-libre 6.14.5
Diffstat (limited to 'emacs/PKGBUILD')
-rwxr-xr-xemacs/PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/emacs/PKGBUILD b/emacs/PKGBUILD
index 076ad99..e137cf6 100755
--- a/emacs/PKGBUILD
+++ b/emacs/PKGBUILD
@@ -4,24 +4,27 @@
# Contributor: Jesús E. <heckyel@hyperbola.info>
# Contributor: Tobias Dausend <throgh@hyperbola.info>
pkgname=emacs
-pkgver=29.4
+pkgver=30.1
_debver=$pkgver
-_debrel=2
-pkgrel=2
+_debrel=5
+pkgrel=5
pkgdesc="The extensible, customizable, self-documenting real-time display editor"
arch=('i686' 'x86_64')
url='https://www.gnu.org/software/emacs/emacs.html'
license=('GPL-3')
depends=('librsvg-legacy' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk' 'hicolor-icon-theme'
- 'desktop-file-utils' 'alsa-lib' 'gnutls' 'jansson')
+ 'desktop-file-utils' 'alsa-lib' 'gnutls' 'jansson' 'libgccjit' 'libisl')
makedepends=('quilt')
source=("https://ftp.gnu.org/gnu/emacs/${pkgname}-${pkgver}.tar.xz"
"https://deb.debian.org/debian/pool/main/e/emacs/emacs_${_debver}+1-${_debrel}~bpo12+1.debian.tar.xz"
+ fix-compile.patch::https://github.com/emacs-mirror/emacs/commit/53a5dada413662389a17c551a00d215e51f5049f.patch
"modify-startup.patch")
-sha512sums=('66b38081cb01d2c46ff7beefb45986cc225b4c922c30712ad0d456c6cae5507176ed99418c8f26948c5375c8afde4e4b2507d23ed997dbb5392d12150a121d80'
- '19e4cdda20009d9dcb65ebc4f6d6b15cb2d0d2927d0a77911196f6a29225b2ebc0a84e9e3cab4dbf6de6dad1ee916b8a8d4cee9c10910b19218874158226ca76'
+sha512sums=('511a6a1d2a170a207913692e1349344b70a0b5202b8d1ae27dc7256e589c77ae9e35da16fc2a098bf9f1b8d0f60233f452ed8d6744b70b907f3484c42f2d7d7f'
+ '55c6ac00a32f8ad0fba530d455916f349775607a3d071e33adccd9ae415511860057b890fcae4670b55f516cdbeb66865d1a2b0f41e678d74b7b635250093f26'
+ '26f50a28ff6d913681d95e890a42aa50258d98c9c314d9984203e6e2fd1daf9c67d2475bca25b76e9e97cd085a82dc3dbdecbba9ec08fa61945c87511efb2dc3'
'223c8992b730678ea67edda8b8a92e779e96cbf9f41b2cb0fc70029ded6bfbedfbebf90f19af6f9a17c9dd16564aa3b6b97623cec8e1d55ead3a3438efbb8250')
prepare() {
+ patch -d ${pkgname}-${pkgver} -Np1 < fix-compile.patch
cd "$srcdir"/$pkgname-$pkgver
if [[ ${pkgver%.*} = ${_debver%.*} ]]; then
# Debian patches
@@ -36,6 +39,7 @@ prepare() {
rm -v debian/patches/0004-Adjust-documentation-references-for-Debian.patch || true
rm -v debian/patches/0005-Modify-the-output-of-version-to-indicate-Debian-modi.patch || true
rm -v debian/patches/0008-Mark-vc-bzr-test-fauilt-bzr-autoloads-as-unstable-fo.patch || true
+ rm -v debian/patches/0018-Fix-eldoc-warning-in-patch-adding-debian-emacs-flavo.patch || true
quilt push -av
fi
# patchout startup-links
@@ -58,6 +62,8 @@ CFLAGS="-O3 -march=native" ./configure \
--without-xft \
--without-sound \
--without-toolkit-scroll-bars \
+ --with-tree-sitter=ifavailable \
+ --with-native-compilation=no \
--without-xaw3d
make ${MAKEFLAGS}
# --without-imagemagick \